Demo Discussion
Forum Config Examples Contributions Vulnerabilities
  Discussion forum about ELOG  Not logged in ELOG logo
icon1.gif   SSL does not work, posted by Hisataka YOSHIDA on Fri Jun 5 03:49:20 2020 
    icon2.gif   Re: SSL does not work, posted by Stefan Ritt on Fri Jun 5 13:24:01 2020 
       icon2.gif   Re: SSL does not work, posted by Hisataka YOSHIDA on Thu Jun 11 08:23:01 2020 
Message ID: 69155     Entry time: Fri Jun 5 13:24:01 2020     In reply to: 69154     Reply to this: 69160
Icon: Reply  Author: Stefan Ritt  Author Email: stefan.ritt@psi.ch 
Category: Bug report  OS: Linux  ELOG Version: 3.1.4-2 
Subject: Re: SSL does not work 

When you compile elog from the soruces, you need the OpenSSL library to be installed. The CMake build process will then find it and include it in the compile process. When you use the "make" build process, you have to make sure that SSL is enabled there:

USE_SSL = 1

To install the OpenSSL library, you can do on most systems something like "sudo yum install openssl-dev" or "sudo apt-get install openssl-dev"

/Stefan

 

Hisataka YOSHIDA wrote:

Hello.

I installed the latest elog (3.1.4-2) in CentOS 7, and it is working well without SSL.
When I enalbled SSL option (SSL = 1) in the "elogd.cfg", and tried to start the elogd, the message below was shown and failed to run.

SSL support not compiled into elogd

If I switched the elog to older one (3.1.4-1), I could successeed to run the elogd with SSL option.
Is there any other option required in the latest elog to run with SSL? Or is this bug in the latest version?

Thank you,
Hisataka YOSHIDA

 

ELOG V3.1.4-80633ba