Demo Discussion
Forum Config Examples Contributions Vulnerabilities
  Discussion forum about ELOG, Page 1 of 729  Not logged in ELOG logo
ID Date Icon Author Author Email Category OS ELOG Version Subject
  69248   Fri Oct 23 15:10:54 2020 Reply Andreas Luedekeandreas.luedeke@psi.chQuestionWindowslatestRe: Field values dependent on other selections

Instead of using three different options you could use the same:

Options Eyepiece = Pentax{a}, TeleVue{b}, Meade{c}

{a} Options Form = 5mm, 20mm, 30mm
{b} Options Form = 7mm Nagler, 10mm Radian, 24mm Panoptic
{c} Options Form = 8.8mm UWA, 14mm UWA, 26mm QX

It makes more sense.
But it is as well possible to supress attributed in the edit from. See

  • Show Attributes = <list>
    Attributes present in this list are shown in the single entry page. Omitting attributes can make sense for attributes which are automatically derived from other attributes via the Change <attribute> command.
  • Show Attributes Edit = <list>
    The same as Show Attributes, but for the entry form.

You just have a different <list> for each conditional case {a} {b} {c}.

Anthony Krishock wrote:

Thanks for your suggestion. Right now, my log is configured as follows:

Options Eyepiece = Pentax{a}, TeleVue{b}, Meade{c}
{a} Options Pentax = 5mm, 20mm, 30mm
{b} Options TeleVue = 7mm Nagler, 10mm Radian, 24mm Panoptic
{c} Options Meade = 8.8mm UWA, 14mm UWA, 26mm QX

If I select "Pentax", I would like the other two options to be unavailable. Instead, all three options are shown. Can I mask the other unused options?

Stefan Ritt wrote:

Look in the manual under "conditional attributes"

Stefan

Anthony Krishock wrote:

All,

I would like to know if there is a way in elog to populate a field based on the value of another field. What I want to do is have a field with a few selections (a menu) and another text field that populates based on what I select from the menu.

 

Is this possible?

 

 

 

  69247   Wed Oct 21 15:14:13 2020 Reply David Walliswallis@aps.anl.govQuestionLinuxELOG V3.1.4-ba8Re: From command line: "command Submit not allowed"

Hi David, thanks for your input!

This logbook has been around for almost 10 years, and has evolved from file-based authentication, to LDAP, and finally to PAM (that can use any of local password files, LDAP, and Active Directory), and I'm thinking that might be the root of this problem. There are old account entries from the file-based days, with passwords, that match the AD usernames. I'm wondering if elogd is trying to use the password in the password file, rather than via PAM. I don't remember the old passwords, so I can't check, and I've run into problems trying to change the passwords. I'm wondering if there's a way to generate a new password from the command line, that would allow me to test the theory.

David Dunne wrote:

FYI, I had problems a few weeks ago trying to get the command line elog working, blamed everybody and everything but myself.

In my case it was command line syntax errors and eventually got it going as part of a nightly script

While testing I ran the Elog Server from the command line in verbose mode to see if that helped determine the problem.

On the server end the logbook uploading to is set for Plaintext

# Set entries to TEXT Only format
Default encoding = 1
Allowed encoding = 1

 

Elog server authenication is standard built in to elogd, no PAM, no LDAP, no Kerberos 

Below is what works for me, I’ve replaced my Elog Server Hostname, Elog Username & Password used to connect to the server with generic.

Elog Server version = elog-3.1.4-2

 

# Log details in Elog Server

/usr/local/bin/elog -h HOSTNAME -p 80 -l Backups -u USERNAME PASSWORD -a Backup=NightlyBackupScript -a Hostname=$HOST -n 1 -x -m /tmp/elog.nightly.script.$TIMESTAMP

 

I've been caught out in the past having a very old version of the elog command line talking to a recent Elog Server build or Encoding not matching

 

David Wallis wrote:

I've been able to work around this by completely turning off authentication, and adding New to the Guest menu list.

One additional question: since I'm uploading historical logbook entries, is it possible to set the entry creation date via the command line? It seems that elogd is overriding the attribute "Date".

David Wallis wrote:

Hmmm... I added "New" to the Guest menu list, and the button showed up for a guest user. But when I submitted the new ticket, I got the message Error: Command "Submit" is not allowed for user ""

Stefan Ritt wrote:

"submit not allowed" you typically get if there is a "guest menu" for read-only access and you are not logged in. I never tried the elog program with PAM authentication, but you said that your turned authentication off. What I would do is to strip down your elogd.cfg to a very simple form until the elog utility works, then figure out which configuration makes the trouble.

Stefan

David Wallis wrote:

Update: I tried switching the logbook to no authentication reqiured, and still get the "command Submit not allowed" response.

David Wallis wrote:

I'm running  Elog version V3.1.4-ba84827 on Red Hat Linux 7.9. As part of migrating from an older in-house logbook to Elog, I need to upload all the old logbook entries. However, when I attempt to do that with the "elog" command line tool, I'm getting the error "command Submit not  allowed.

I read through a similar report from 2015 (entry #68149), but none of the potential causes seem to be at play here. The logbook is using PAM authentication, and I can log in to the web interface using the same credentials I'm using from the command line. The other case mentioned a dis-allowed encoding format, but my logbook is configured to allow all formats.

 

This is the command line I'm using:

/usr/local/elog/bin/elog -v -h logbook.aps.anl.gov -p 8081 -l On_Call -x -n 2 -a Date='10/19/2020 01:02' Author="David Wallis" Title='Test Upload' Status='Open' System='On-Call' -u 'wallis' '*****'  "This is a test message"

 

 

 

 

 

 

  69246   Wed Oct 21 03:08:21 2020 Reply David Dunneddunne@seven.com.auQuestionLinuxELOG V3.1.4-ba8Re: From command line: "command Submit not allowed"

FYI, I had problems a few weeks ago trying to get the command line elog working, blamed everybody and everything but myself.

In my case it was command line syntax errors and eventually got it going as part of a nightly script

While testing I ran the Elog Server from the command line in verbose mode to see if that helped determine the problem.

On the server end the logbook uploading to is set for Plaintext

# Set entries to TEXT Only format
Default encoding = 1
Allowed encoding = 1

 

Elog server authenication is standard built in to elogd, no PAM, no LDAP, no Kerberos 

Below is what works for me, I’ve replaced my Elog Server Hostname, Elog Username & Password used to connect to the server with generic.

Elog Server version = elog-3.1.4-2

 

# Log details in Elog Server

/usr/local/bin/elog -h HOSTNAME -p 80 -l Backups -u USERNAME PASSWORD -a Backup=NightlyBackupScript -a Hostname=$HOST -n 1 -x -m /tmp/elog.nightly.script.$TIMESTAMP

 

I've been caught out in the past having a very old version of the elog command line talking to a recent Elog Server build or Encoding not matching

 

David Wallis wrote:

I've been able to work around this by completely turning off authentication, and adding New to the Guest menu list.

One additional question: since I'm uploading historical logbook entries, is it possible to set the entry creation date via the command line? It seems that elogd is overriding the attribute "Date".

David Wallis wrote:

Hmmm... I added "New" to the Guest menu list, and the button showed up for a guest user. But when I submitted the new ticket, I got the message Error: Command "Submit" is not allowed for user ""

Stefan Ritt wrote:

"submit not allowed" you typically get if there is a "guest menu" for read-only access and you are not logged in. I never tried the elog program with PAM authentication, but you said that your turned authentication off. What I would do is to strip down your elogd.cfg to a very simple form until the elog utility works, then figure out which configuration makes the trouble.

Stefan

David Wallis wrote:

Update: I tried switching the logbook to no authentication reqiured, and still get the "command Submit not allowed" response.

David Wallis wrote:

I'm running  Elog version V3.1.4-ba84827 on Red Hat Linux 7.9. As part of migrating from an older in-house logbook to Elog, I need to upload all the old logbook entries. However, when I attempt to do that with the "elog" command line tool, I'm getting the error "command Submit not  allowed.

I read through a similar report from 2015 (entry #68149), but none of the potential causes seem to be at play here. The logbook is using PAM authentication, and I can log in to the web interface using the same credentials I'm using from the command line. The other case mentioned a dis-allowed encoding format, but my logbook is configured to allow all formats.

 

This is the command line I'm using:

/usr/local/elog/bin/elog -v -h logbook.aps.anl.gov -p 8081 -l On_Call -x -n 2 -a Date='10/19/2020 01:02' Author="David Wallis" Title='Test Upload' Status='Open' System='On-Call' -u 'wallis' '*****'  "This is a test message"

 

 

 

 

 

  69245   Wed Oct 21 02:27:43 2020 Reply Anthony Krishockajkrishock@verizon.netQuestionWindowslatestRe: Field values dependent on other selections

Thanks for your suggestion. Right now, my log is configured as follows:

Options Eyepiece = Pentax{a}, TeleVue{b}, Meade{c}
{a} Options Pentax = 5mm, 20mm, 30mm
{b} Options TeleVue = 7mm Nagler, 10mm Radian, 24mm Panoptic
{c} Options Meade = 8.8mm UWA, 14mm UWA, 26mm QX

If I select "Pentax", I would like the other two options to be unavailable. Instead, all three options are shown. Can I mask the other unused options?

Stefan Ritt wrote:

Look in the manual under "conditional attributes"

Stefan

Anthony Krishock wrote:

All,

I would like to know if there is a way in elog to populate a field based on the value of another field. What I want to do is have a field with a few selections (a menu) and another text field that populates based on what I select from the menu.

 

Is this possible?

 

 

Attachment 1: Capture.JPG
Capture.JPG
  Draft   Wed Oct 21 02:26:32 2020 Reply Anthony Krishockajkrishock@verizon.netQuestionWindowslatestRe: Field values dependent on other selections

Thanks for your suggestion.. Is it possible to, once 

Stefan Ritt wrote:

Look in the manual under "conditional attributes"

Stefan

Anthony Krishock wrote:

All,

I would like to know if there is a way in elog to populate a field based on the value of another field. What I want to do is have a field with a few selections (a menu) and another text field that populates based on what I select from the menu.

 

Is this possible?

 

 

  69243   Tue Oct 20 20:44:03 2020 Reply David Walliswallis@aps.anl.govQuestionLinuxELOG V3.1.4-ba8Re: From command line: "command Submit not allowed"

I've been able to work around this by completely turning off authentication, and adding New to the Guest menu list.

One additional question: since I'm uploading historical logbook entries, is it possible to set the entry creation date via the command line? It seems that elogd is overriding the attribute "Date".

David Wallis wrote:

Hmmm... I added "New" to the Guest menu list, and the button showed up for a guest user. But when I submitted the new ticket, I got the message Error: Command "Submit" is not allowed for user ""

Stefan Ritt wrote:

"submit not allowed" you typically get if there is a "guest menu" for read-only access and you are not logged in. I never tried the elog program with PAM authentication, but you said that your turned authentication off. What I would do is to strip down your elogd.cfg to a very simple form until the elog utility works, then figure out which configuration makes the trouble.

Stefan

David Wallis wrote:

Update: I tried switching the logbook to no authentication reqiured, and still get the "command Submit not allowed" response.

David Wallis wrote:

I'm running  Elog version V3.1.4-ba84827 on Red Hat Linux 7.9. As part of migrating from an older in-house logbook to Elog, I need to upload all the old logbook entries. However, when I attempt to do that with the "elog" command line tool, I'm getting the error "command Submit not  allowed.

I read through a similar report from 2015 (entry #68149), but none of the potential causes seem to be at play here. The logbook is using PAM authentication, and I can log in to the web interface using the same credentials I'm using from the command line. The other case mentioned a dis-allowed encoding format, but my logbook is configured to allow all formats.

 

This is the command line I'm using:

/usr/local/elog/bin/elog -v -h logbook.aps.anl.gov -p 8081 -l On_Call -x -n 2 -a Date='10/19/2020 01:02' Author="David Wallis" Title='Test Upload' Status='Open' System='On-Call' -u 'wallis' '*****'  "This is a test message"

 

 

 

 

  69242   Tue Oct 20 18:40:05 2020 Reply Stefan Rittstefan.ritt@psi.chQuestionLinuxELOG V3.1.4-ba8Re: From command line: "command Submit not allowed"

Giving up. Send me your config file and I will debug it.

Stefan

David Wallis wrote:

Hmmm... I added "New" to the Guest menu list, and the button showed up for a guest user. But when I submitted the new ticket, I got the message Error: Command "Submit" is not allowed for user ""

Stefan Ritt wrote:

"submit not allowed" you typically get if there is a "guest menu" for read-only access and you are not logged in. I never tried the elog program with PAM authentication, but you said that your turned authentication off. What I would do is to strip down your elogd.cfg to a very simple form until the elog utility works, then figure out which configuration makes the trouble.

Stefan

David Wallis wrote:

Update: I tried switching the logbook to no authentication reqiured, and still get the "command Submit not allowed" response.

David Wallis wrote:

I'm running  Elog version V3.1.4-ba84827 on Red Hat Linux 7.9. As part of migrating from an older in-house logbook to Elog, I need to upload all the old logbook entries. However, when I attempt to do that with the "elog" command line tool, I'm getting the error "command Submit not  allowed.

I read through a similar report from 2015 (entry #68149), but none of the potential causes seem to be at play here. The logbook is using PAM authentication, and I can log in to the web interface using the same credentials I'm using from the command line. The other case mentioned a dis-allowed encoding format, but my logbook is configured to allow all formats.

 

This is the command line I'm using:

/usr/local/elog/bin/elog -v -h logbook.aps.anl.gov -p 8081 -l On_Call -x -n 2 -a Date='10/19/2020 01:02' Author="David Wallis" Title='Test Upload' Status='Open' System='On-Call' -u 'wallis' '*****'  "This is a test message"

 

 

 

 

  69241   Tue Oct 20 18:26:26 2020 Reply David Walliswallis@aps.anl.govQuestionLinuxELOG V3.1.4-ba8Re: From command line: "command Submit not allowed"

Hmmm... I added "New" to the Guest menu list, and the button showed up for a guest user. But when I submitted the new ticket, I got the message Error: Command "Submit" is not allowed for user ""

Stefan Ritt wrote:

"submit not allowed" you typically get if there is a "guest menu" for read-only access and you are not logged in. I never tried the elog program with PAM authentication, but you said that your turned authentication off. What I would do is to strip down your elogd.cfg to a very simple form until the elog utility works, then figure out which configuration makes the trouble.

Stefan

David Wallis wrote:

Update: I tried switching the logbook to no authentication reqiured, and still get the "command Submit not allowed" response.

David Wallis wrote:

I'm running  Elog version V3.1.4-ba84827 on Red Hat Linux 7.9. As part of migrating from an older in-house logbook to Elog, I need to upload all the old logbook entries. However, when I attempt to do that with the "elog" command line tool, I'm getting the error "command Submit not  allowed.

I read through a similar report from 2015 (entry #68149), but none of the potential causes seem to be at play here. The logbook is using PAM authentication, and I can log in to the web interface using the same credentials I'm using from the command line. The other case mentioned a dis-allowed encoding format, but my logbook is configured to allow all formats.

 

This is the command line I'm using:

/usr/local/elog/bin/elog -v -h logbook.aps.anl.gov -p 8081 -l On_Call -x -n 2 -a Date='10/19/2020 01:02' Author="David Wallis" Title='Test Upload' Status='Open' System='On-Call' -u 'wallis' '*****'  "This is a test message"

 

 

 

ELOG V3.1.4-80633ba