Demo Discussion
Forum Config Examples Contributions Vulnerabilities
  Discussion forum about ELOG  Not logged in ELOG logo
icon5.gif   OSX Issues, posted by Florian Heigl on Tue Jul 5 19:10:48 2022 
    icon2.gif   Re: OSX Issues, posted by Stefan Ritt on Fri Jul 29 14:22:00 2022 
Message ID: 69540     Entry time: Tue Jul 5 19:10:48 2022     Reply to this: 69551
Icon: Question  Author: Florian Heigl  Author Email: me@florianheigl.me 
Category: Question  OS: Mac OSX  ELOG Version: 3.1.4 
Subject: OSX Issues 

Hi, I have an issue with my local elog setup. it's usable but one function is just not working.

Problem

I'm getting weird error messages when trying to write or read entries from the CLI client.

I have googled a lot and most elog client examples are not giving the actual output, more like elog -h <host> -p <myport> -a ... -x -m "myfile" but I hope I got the options right.

Upgrading did not change the behaviour.

Question?

  • anyone see problems in the commands I tried below
  • with OSX in general
  • have a recent setup on OSX that just works

 

Env

I'm running elog on my OSX laptop for tracking issues / improvements on client's IT systems. It's proven really good for storing my notes.

One "kink" is I kinda need both of them on the laptop since I cannot assume to have working network connectivity, i.e. when documenting network outages or datacenter maintenance where everything is off.

One thing I couldn't get to work was the CLI. Today I upgraded to the latest build, and tried again.

Env: OSX 12.4 (x86_64)

 

elog Client compiled from latest source tree (bcd7b50edd3d687425e6c5b0906dc02c8690a24e)

with minimal adjustments (turn off SSL since I can't get it right on OSX, rename two .c files in mxml to .cxx)

 

Outputs

 

$ echo "blah" | ./elog -h 127.0.0.1 -p 8080 -l intern -r 2 -x
Cannot retrieve host name: Undefined error: 0
$ echo "blah" | ./elog -h 127.0.0.1 -p 8080 -l intern -r 2 -x
Cannot retrieve host name: Undefined error: 0
$ host 127.0.0.1
1.0.0.127.in-addr.arpa domain name pointer localhost.
$ elog -?
elogd 3.1.4 built Oct  8 2020, 03:14:21 revision 7c3fd00b
$ elog -?                                                                       
elogd 3.1.4 built Jul  5 2022, 18:23:30 revision bcd7b50e


As per the messages, I'm not entirely sure if it's an issue with the client or the server. upgrading both components made no difference.

Config

Theme = default
Comment = Logbuch Findings etc
Attributes = Context, Type, Category, Subject, ObjectPath
Options Context = global, intern, [redacted]
Options Type = Anpassung, Finding, Problem, Update, Auftrag, Planung
Options Category = General, Hardware, Software, Network, Other
Extendable Options = Category
Required Attributes = Context, Type, ObjectPath
Page Title = ELOG - $subject
Reverse sort = 1
Quick filter = Date, Context, Type

 

make output


$ gmake                                                
c++ -O3 -funroll-loops -fomit-frame-pointer -W -Wall -Wno-deprecated-declarations -Wno-unused-result -Imxml -I/opt/local/include -o elog src/elog.cxx mxml.o crypt.o -L/opt/local/lib
ld: warning: directory not found for option '-L/opt/local/lib'
c++ -O3 -funroll-loops -fomit-frame-pointer -W -Wall -Wno-deprecated-declarations -Wno-unused-result -Imxml -I/opt/local/include -w -c -o auth.o src/auth.cxx
c++ -O3 -funroll-loops -fomit-frame-pointer -W -Wall -Wno-deprecated-declarations -Wno-unused-result -Imxml -I/opt/local/include -o elogd src/elogd.cxx auth.o mxml.o crypt.o -L/opt/local/lib
ld: warning: directory not found for option '-L/opt/local/lib'
c++ -O3 -funroll-loops -fomit-frame-pointer -W -Wall -Wno-deprecated-declarations -Wno-unused-result -Imxml -I/opt/local/include -o elconv src/elconv.cxx -L/opt/local/lib
ld: warning: directory not found for option '-L/opt/local/lib'

$ ls -ltr
[...]
-rw-r--r--   1 floh  staff     4811  5 Jul 17:58 CMakeLists.txt
drwxr-xr-x  25 floh  staff      800  5 Jul 17:58 doc
drwxr-xr-x  10 floh  staff      320  5 Jul 17:58 scripts
drwxr-xr-x  13 floh  staff      416  5 Jul 17:58 src
drwxr-xr-x  10 floh  staff      320  5 Jul 18:15 mxml
-rw-r--r--   1 floh  staff    36424  5 Jul 18:15 mxml.o
-rw-r--r--   1 floh  staff     8784  5 Jul 18:15 crypt.o
-rw-r--r--   1 floh  staff     5886  5 Jul 18:23 Makefile
-rwxr-xr-x   1 floh  staff    90840  5 Jul 18:23 elog
-rw-r--r--   1 floh  staff     2976  5 Jul 18:23 auth.o
-rwxr-xr-x   1 floh  staff  1390664  5 Jul 18:23 elogd
-rwxr-xr-x   1 floh  staff    52112  5 Jul 18:23 elconv


$ sudo gmake install
Password:
install: elog -> /usr/local/bin/elog
install: elconv -> /usr/local/bin/elconv
install: elogd -> /usr/local/sbin/elogd
install: man/elog.1 -> /usr/local/man/man1//elog.1
install: man/elconv.1 -> /usr/local/man/man1//elconv.1
install: man/elogd.8 -> /usr/local/man/man8//elogd.8
install: scripts/ckeditor-config.js -> /usr/local/elog/scripts//ckeditor-config.js
install: scripts/dnd.js -> /usr/local/elog/scripts//dnd.js
install: scripts/elcode.js -> /usr/local/elog/scripts//elcode.js
install: scripts/im.js -> /usr/local/elog/scripts//im.js
install: scripts/jquery-1.11.1.min.js -> /usr/local/elog/scripts//jquery-1.11.1.min.js
install: scripts/load-ckeditor.js -> /usr/local/elog/scripts//load-ckeditor.js
Installing CKeditor to /usr/local/elog/scripts/ckeditor
Installing resources to /usr/local/elog/resources
Installing themes to /usr/local/elog/themes
Installing example logbook to /usr/local/elog/logbooks/demo
install: logbooks/demo/2001/011108a.log -> /usr/local/elog/logbooks/demo/2001/011108a.log
install: elogd.plist -> /Library/LaunchDaemons/ch.psi.elogd.plist
The elogd service can now be started with
  sudo launchctl load /Library/LaunchDaemons/ch.psi.elogd.plist

ELOG V3.1.4-bcd7b50