Demo Discussion
Forum Config Examples Contributions Vulnerabilities
  Discussion forum about ELOG  Not logged in ELOG logo
icon5.gif   OSX Issues, posted by Florian Heigl on Tue Jul 5 19:10:48 2022 
    icon2.gif   Re: OSX Issues, posted by Stefan Ritt on Fri Jul 29 14:22:00 2022 
Message ID: 69551     Entry time: Fri Jul 29 14:22:00 2022     In reply to: 69540
Icon: Reply  Author: Stefan Ritt  Author Email: stefan.ritt@psi.ch 
Category: Question  OS: Mac OSX  ELOG Version: 3.1.4 
Subject: Re: OSX Issues 

I just tried the same on my latpop (MacOSX 12.4) and it worked flawlessly:

ritt@MBP14 build % echo "blah" | ./elog -h 127.0.0.1 -p 8080 -l demo -r 2 -x
Message successfully transmitted, ID=3
ritt@MBP14 build % host 127.0.0.1
Host 1.0.0.127.in-addr.arpa. not found: 3(NXDOMAIN)
ritt@MBP14 build % echo "blah" | ./elog -h localhost -p 8080 -l demo -r 2 -x
Message successfully transmitted, ID=4
ritt@MBP14 build %

So have you tried with the "-v" flag? Maybe your network is not correctly configured. You can also try the "curl" utility (see elog:68597), maybe you see some different error there. You get that via MacPorts.

Stefan

 

ELOG V3.1.4-bcd7b50