DRS4 Forum
  DRS4 Discussion Forum, Page 43 of 44  Not logged in ELOG logo
    Reply  Thu Jan 25 06:10:52 2018, chen wenjun, drscl doesn't find eval board but drsosc does (Windows 7) 
Hi! Jim:

  It seems that I meet the same question with you ,and I am confused ,have you find out the reason about this problem?Or can you tell me
how you deal with it?
    Reply  Thu Jan 25 08:07:32 2018, chen wenjun, problem with the drscl(drs507) 
I have tried about 4 computers,only one worked fine.I truly want to know how others get this fixed,can you get in touch with them?

Ritt wrote:

This problem has been reported by several people, like 
Entry  Wed Mar 14 09:13:39 2018, chen wenjun, confusion about the description in drs.cpp 20180314161201.jpg

  recently,whtn I study the drs.cpp code ,I found that  the buffer[1] is char but the addr and the base_addr are all unsigned int,isn't
there any problem that the addr may be cut off to 8 bits? Also ,I found that the data fpga recieved from the usb is 16 bits,so how can fpga get the true
    Reply  Sun May 6 08:13:37 2018, chen wenjun, confusion about the description in drs.cpp 
Hi Stefan:

  I'm still confused that althought the 8 bits buffer is enough,the FPGA receive the command through the uc_data_i register which is
16 bits wides.As we can see in the firmware, the locbus_addr is 32 bits wides. Does it means the locbus_addr[31:8] are always '0' because the address
Entry  Wed Nov 22 08:31:03 2017, chen wenjun , using of the DRS Command Line Interface ΞΆΠΕΝΌΖ¬_20171122153834.png
Hello! I'm using DRS4 evaluation board V5 with the drs command line interface,but the mannal only explained the meaning of the command--"info".And
I can't get the hang of the use of other commands through "help",so is there anywhere can I learn more about other commands?Or I can only
learn it through the datasheet of DRS4 chip.
    Reply  Wed Nov 22 08:58:33 2017, chen wenjun , using of the DRS Command Line Interface ΞΆΠΕΝΌΖ¬_20171122160245.png
OK!Thank you! One more question,when I use the Oscillocope ,I found that the actual speed is a constant value of 1.007G,how can change this speed.

Ritt wrote:

The command line interface is more a debugging tool for experts, and
    Reply  Wed Nov 22 09:19:11 2017, chen wenjun , using of the DRS Command Line Interface 
Thank you very much !! All my fault for I thought it too comlicated. Thank you sincerely!

Ritt wrote:

Remove the check mark from the "Lock" box and enter a different
Entry  Tue Aug 27 08:33:22 2019, chinmay basu, DRS4 
Is DRS4 suitable for use with Silicon surface barrier detectors?
Entry  Fri Aug 7 18:41:37 2015, dante, DRS4 

I have just installed DRS4, but when I try to view it from the USB it don't work. Why?

Entry  Thu Nov 1 20:08:33 2012, hongwei yang, DRS4 firmware 
    We are using drs4 board, but oscilloscope app will somehow stop to work if we config trigger into "or and", When I
look into the drs4 firmware file drs4_eval3_app.vhd, I couldn't find the trigger_config value assignment which is mentioned at(#7 offset 0x1E from 31 downto
    Reply  Thu Nov 1 20:21:44 2012, hongwei yang, DRS4 firmware 

            Stefan Ritt wrote:
    Reply  Thu Nov 1 20:25:53 2012, hongwei yang, DRS4 firmware 

            hongwei yang wrote:
    Reply  Thu Nov 1 20:46:53 2012, hongwei yang, DRS4 firmware 

            Stefan Ritt wrote:
Entry  Tue Dec 10 14:48:42 2013, ismail okan atakisi, measurement range 
I m trying to measure lifetime in our lab and I intend to take 
measurement with DRS4 at that point I have a little bit confused  about 
DRS4 time range.In My system I opened 10 us gate but after triggering 
Entry  Tue Aug 27 16:14:49 2013, lengchongyang,  
  Hello everyone!I'm a new user of DRS4 board,but it seems that some files are missing
in my demo project.So I hope someone could help me by sending a correct VHDL hardware project to my Email:lcyiss900@gmail.com.Thanks in advance!
    Reply  Wed Aug 28 04:05:48 2013, lengchongyang,  

            lengchongyang wrote:
              Hello everyone!I'm a new user of DRS4
Entry  Tue Apr 13 10:45:18 2010, lorenzo neri, evaluation board used like a counter 
Hi all

Entry  Wed Dec 23 15:38:14 2015, mony orbach, Dtap stops toggling after 40msec 

the drs4 start to generate Dtap signal after reset and standard configuration.

while in reset Denable and  Dwrite are low
    Reply  Thu Dec 24 10:51:31 2015, mony orbach, Dtap stops toggling after 40msec 
my refclk is 1.25Mhz

what are the inputs and voltage you need to see?

Avdd and Dvdd are 2.5v
    Reply  Sun Dec 27 15:06:59 2015, mony orbach, Dtap stops toggling after 40msec 

We have some meesurs to show (attached)

Dtap and Denable
Dtap+Denable in zoom
Dtap + Ref+
Dtap + Dspeed

From the screen shots
ELOG V3.1.5-fc6679b