DRS4 Forum
  DRS4 Discussion Forum  Not logged in ELOG logo
Entry  Wed Dec 23 15:38:14 2015, mony orbach, Dtap stops toggling after 40msec 
    Reply  Wed Dec 23 15:48:42 2015, Stefan Ritt, Dtap stops toggling after 40msec 
       Reply  Thu Dec 24 10:51:31 2015, mony orbach, Dtap stops toggling after 40msec 
          Reply  Thu Dec 24 12:45:41 2015, Stefan Ritt, Dtap stops toggling after 40msec 
             Reply  Sun Dec 27 15:41:32 2015, mony orbach, Dtap stops toggling after 40msec Dtap-Denable.gifdtap-Danable2.gifDtap-refck.gifDtap-Dspeed.gif
                Reply  Mon Dec 28 11:05:15 2015, Stefan Ritt, Dtap stops toggling after 40msec 
                   Reply  Mon Dec 28 11:21:54 2015, mony orbach, Dtap stops toggling after 40msec 
                      Reply  Wed Dec 30 16:25:35 2015, mony orbach, Dtap stops toggling after 40msec 
                         Reply  Wed Dec 30 17:00:00 2015, Stefan Ritt, Dtap stops toggling after 40msec 
                            Reply  Thu Jan 14 14:00:26 2016, mony orbach, Dtap stops toggling after 40msec 
                               Reply  Thu Jan 14 14:11:06 2016, Stefan Ritt, Dtap stops toggling after 40msec 
Message ID: 463     Entry time: Mon Dec 28 11:05:15 2015     In reply to: 462     Reply to this: 464
Author: Stefan Ritt 
Subject: Dtap stops toggling after 40msec 

Thanks for posting the plots. It really looks like the PLL is not working. I see two possible reasons: 1) The PLLEN bit in the configuration register is not set and 2) The REFCLK signal does not reach the chip. We had cases whrere people had a hard time to solder the DRS4 correctly due to the small pins. So if the REFCLK+ and REFCLK- signals have a poor connection, then the PLL of course won't work. Putting some more tin at the pins manually usually helps. Or remove the chip completely and try with another chip. In theory there is the possibility that the internal bond wire of the REFCLK signal has a bad connection, but we tested all chips we send out so we should have seen that. But trying with another chip cannot hurt in general. Next month I'm coming to the Weizman Institute for the ISOTDAQ shool. If you want we can meet there if you don't mind the 120 km drive from Haifa.

Stefan

mony orbach wrote:

Hi

We have some measures to show (attached)

  1. Dtap and Denable
  2. Dtap+Denable in zoom
  3. Dtap + Refck+
  4. Dtap + Dspeed

From the screen shots it can be seen that refck+ is not synchronized with Dtap (PLL not working correctly)

And Dspeed is going done to zero after some time.

In our system Dspeed is shorted to pllout.

So it looks like pllout do not pump the RC filter capacitors.

We tested various value of R and C's.

Also we checked that pllout is sorted to Dspeed.

 

Thanks, mony

 

ELOG V3.1.4-80633ba